Communauté Informatique NDFR.net : TightVNC (vncserver) sous linux (Fedora) - Page 2 - Unix/Linux Client
Répondre
TightVNC (vncserver) sous linux (Fedora)
Outils du sujet Modes d'affichage
  #16  
Ancien 16 May 2006, 11h39
nono_95 nono_95 est hors ligne
Membre junior
 
Date d'inscription: 15/05/2006
Messages: 5
J'ai le même problème....
Même en utilisant x11vnc, ca ne fonctionne pas!
D'ailleurs, en lançant la commande donnée par Knux, j'obtiens une erreur

Mon serveur VNC (tightVNC plus précisement) se trouve sur un Linux Debian avec une interface fluxbox. Et j'essaie (déséperement) d'y accéder par un windows XP.

J'attends vos conseils et remarques!
Merci
Réponse avec citation
  #17  
Ancien 16 May 2006, 17h04
Avatar de KnuX
KnuX KnuX est hors ligne
Membre senior
 
Date d'inscription: 08/12/2002
Lieu: Arras
Âge: 33
Messages: 1 117
On veut l'erreur !
__________________
http://max.skyrock.com/
Réponse avec citation
  #18  
Ancien 17 May 2006, 16h35
nono_95 nono_95 est hors ligne
Membre junior
 
Date d'inscription: 15/05/2006
Messages: 5
voici l'erreur (bonne lecture ) :
admin@Serveur1:~$ x11vnc -display :0

Settings:
display: :0
authfile: null
subwin: 0x0
rootshift: 0
flashcmap: 0
force_idx: 0
overlay: 0
ovl_cursor: 1
visual: null
scaling: 0 1.00000
viewonly: 0
shared: 0
conn_once: 1
inetd: 0
connect: null
connectfile null
vnc_conn: 1
allow: null
passfile: null
accept: null
gone: null
using_shm: 1
flipbytes: 0
onetile: 0
blackout: null
xinerama: 0
xrandr: 0
xrandrmode: null
logfile: null
rc_file:
norc: 0
bg: 0
mod_tweak: 1
isolevel3: 0
xkb: 0
skipkeys: null
addkeysyms: 0
xkbcompat: 0
clearmods: 0
remap: null
norepeat: 1
nofb: 0
watchbell: 1
watchsel: 1
watchprim: 1
cursor: 1
root_curs: 0
curs_mode: null
xfixes: 1
cursorshp: 1
cursorpos: 1
xwarpptr: 0
buttonmap: null
dragging: 1
ptr_mode: 2
inputskip: 10
debug_ptr: 0
debug_key: 0
defer: 30
waitms: 30
take_naps: 0
sb: 60
sigpipe: null
threads: 0
fs_frac: 0.75
gaps_fill: 4
grow_fill: 3
tile_fuzz: 2
deny_all: 0
noremote: 0

17/05/2006 16:37:28 x11vnc version: 0.7pre lastmod: 2004-12-20
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

17/05/2006 16:37:28 XOpenDisplay failed (:0)
admin@Serveur1:~$


Merci
Réponse avec citation
  #19  
Ancien 17 May 2006, 17h59
Avatar de KnuX
KnuX KnuX est hors ligne
Membre senior
 
Date d'inscription: 08/12/2002
Lieu: Arras
Âge: 33
Messages: 1 117
Le serveur X que x11vnc va exploiter doit déjà être exécuté.

Là, il cherche sur le display :0, il faut donc que le serveur y soit exécuté et que l'utilisateur par qui tu lances la commande soit autorisé à s'y connecter (root, c'est ok ).
__________________
http://max.skyrock.com/
Réponse avec citation
  #20  
Ancien 18 May 2006, 12h04
nono_95 nono_95 est hors ligne
Membre junior
 
Date d'inscription: 15/05/2006
Messages: 5
Merci beaucoup Knuxx!!!
ca marche nikel

Et je viens de me rendre compte qu'il n'est meme pas nécessaire d'installer tightvncserver! (x11vnc fonctionne tout seul, comme un grand lol )

Par contre, viens un autre soucis: il n'y a absolument aucune sécurité:
je veux dire par là que celui qui connait l'IP du server, peut se connecter dessus (il n'y a pas de prompt du type: "un utilisateur XXX.XXX.XXX.XXX tente de se connecter sur votre machine. Voulez-vous l'autoriser?")

Je ne fais pas de critique et sans vouloir offenser qui que ce soit, mais ce qu'il manque à x11vnc, c'est:
1) une interface de configuration (autoriser une adresse ou une plage d'adresse IP),
2) le prompt sur le serveur pour valider la connection,
3) la possibilité d'ouvrir un second display qui ne soit pas lié au display :0
Bon, je sais, j'en demande beaucoup....

Si quelqu'un sait quel fichier modifier pour réaliser une (ou toutes ) des options que je viens de citer, merci de le faire savoir!

Merci à tous pour votre aide

Nono
Réponse avec citation
  #21  
Ancien 18 May 2006, 13h29
Avatar de KnuX
KnuX KnuX est hors ligne
Membre senior
 
Date d'inscription: 08/12/2002
Lieu: Arras
Âge: 33
Messages: 1 117
Mets toi un mot de passe
__________________
http://max.skyrock.com/
Réponse avec citation
  #22  
Ancien 18 May 2006, 13h36
nono_95 nono_95 est hors ligne
Membre junior
 
Date d'inscription: 15/05/2006
Messages: 5
ouai!
j'y ai pensé....
mais ça ne semble pas suffisant à mon goût!

Pour ceux qui serait intéressé par un mot de passe pour x11vnc, je donne le lien (que j'ai repris de Knuxx ) :
http://www.karlrunge.com/x11vnc/#faq-passwd

J'attends vos soluces pour les options que j'ai proposés précédemment...

Merci
Réponse avec citation
Répondre

Signets


Utilisateurs actuellement actifs visualisant ce sujet : 1 (0 membres et 1 invités)
 
Outils du sujet
Modes d'affichage

Règles des messages
Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas poster de réponses
Vous ne pouvez pas envoyer de pièces jointes
Vous ne pouvez pas éditer vos messages

Le code BB est oui
Les Smilies sont activés : oui
Le code [IMG] est activé : oui
Le code HTML est activé : non

Aller au forum

Sujets similaires
Sujet Auteur Forum Réponses Dernier message
init 3 sous Fedora Core 1 chriscou Unix/Linux Client 4 22 May 2004 23h16
Pétition - jeux sous linux fonji Vos news 20 21 May 2004 22h37
Connexion internet sous fedora core lili Unix/Linux Client 6 4 May 2004 19h02
Décaler l'affichage d'un bureau sous Linux (Fedora) KnuX Unix/Linux Client 11 20 February 2004 21h40
Premiers pas sous Linux Fred Articles 19 21 October 2003 05h46

Toutes les heures sont au format GMT +2. Il est actuellement 21h58.

Activé par vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.